Forum

Notifications
Clear all

Stories on established database has no text

wolfiejinn
(@wolfiejinn)
Active Member

URL to your eFiction: http://www.roytoys.net/fanfiction/index.php
Version of eFiction: 3.5.2
Have you bridged eFiction, if so with what?: I have no idea what this means...
Version of PHP:  3.2.4
Version of MySQL: 4.1.22
Have you searched for your problem: Yes but most seem to be people with new databases or issues slightly different from my own.
If so, what terms did you try: Looking through the past 10 pages of topics
State the nature of your problem: Not receiving any errors since I updated to the latest version.  I moved to a new host server a month ago and I'm working out some issues, however this one is confusing.  New users can create accounts, reviews can be posted, previously uploaded stories appear and can be read.  New stories, however, do not show up.  You can add the story, the series, title, author name, everything but the actual text of the story.  It shows no errors. Even shows the review box.  If you look at the site, the 'test' I used to verify a user's issue was the poem 'Red'.  Everything works except the actual text of the story.
Do you have a test account for us? I have no idea how to make one of those so no?

Quote
Topic starter Posted : 29/03/2010 3:32 am
Elle
 Elle
(@jenny)
Honorable Member

Is there any story text in the actual database? (You can use phpMyadmin to check.)

archive: dramione.org
site: accio.nu

Available for skin/mod commission! 🙂

ReplyQuote
Posted : 29/03/2010 3:43 am
wolfiejinn
(@wolfiejinn)
Active Member

I guess I'm not understanding what you mean by checking the admin php.  Assume I know jack about any of this and you'd be close onto correct.  I can do basic html and am still stunned stupid that I've accomplished as much with this database as I have thus far in two years.

Under the stories folder, there are numbered folders which I assume are the users who have uploaded files, as the file labeled '1' seems to hold all of mine.  Each of the files in this folder has a numbered label as well.  1.txt is my story "In the Big Leagues".  I have not opened all 50 or so of these text files to see which one is or is not the poem I uploaded today...

Edit: I downloaded these .txt files and opened them.  None of them are the poem I posted so I guess the text is not in the actual database.  I keep reading about this 777 change but I have no idea what that means or what it is in reference too.  Is this my culprit?

ReplyQuote
Topic starter Posted : 29/03/2010 3:58 am
Lyndsie
(@lyndsie)
Member Moderator

So it sounds like you've got your story text storage method set to files, correct? You want to make sure that the story folder as well as all the folders within it are CHMODed properly. Most of the time 755 will be okay, but some servers need them to be at 777, and in fact, the folders by uid should be created at that level. (Although I had many that weren't, which means most likely some prior version of the script created them at 755. My site's been around since version 1.0, though, so there are some anomalous things like that which crop up from time to time.)

http://efiction.org/wiki/index.php5?title=CHMOD

When I recently switched hosts, for whatever reason (they weren't too clear with me), the .txt files also needed to be at a different permission level (666 instead of 644). But eventually once they changed their stuff around so that was no longer the case. So you may end up having to talk to your host.

ReplyQuote
Posted : 29/03/2010 5:51 am
wolfiejinn
(@wolfiejinn)
Active Member

Okay most of that means absolutely nothing to me, and the wiki was even less help.  Where do you find these numbers to verify?

I did however find that the safe mode for the php whatever is turned off so it should be storing things from that perspective.  I cannot stress enough that I understand absolutely NONE of what any of this stuff means.  Not a single word.  It's just numbers and jibberish.

From Wiki linked above:
You can CHMOD your files via your FTP agent or your website's control panel. The exact command depends on the specific setting of your program. Look for the word "permissions" or "attributes". Some FTP programs allow you to just enter a specific number, but most present you with a chart to select the permissions. Basically, when you CHMOD a file, you are setting who can read, write and execute a file, and you are granting permissions to the user who owns the file (user), the group who owns the file (group) or other. If a file is CHMODed to 644, then that means that the file can be read by anyone, edited by the user who owns the file and is executable by no one. For security reasons, these are the CHMOD settings for most files. Folders are usually set to 755 (sometimes 777).

I go to my Cpanel, there is nothing ANYWHERE that mentions Permissions, Attributes or anything like that under the two areas that mention php.  I go to the adminPHP and clicked on every single tab and none of them show either of these words.

All I know is the idiot that I once had my website on was making me pay for HIS host server and I realized for the same money I could have my own and not have to trip over him or complain everytime he decided he was going to play around with my web site cuz he was bored.  So I got my own.  I'm having to learn how to do everything from scratch and do not understand why everything else works but the stories.

And if the default for eFiction is file folder storage then that's what I have because I changed none of that. Pretend I'm an idiot (shouldn't be hard at this rate *sigh*)  *bangs head on keyboard*

ReplyQuote
Topic starter Posted : 30/03/2010 3:34 am
Lyndsie
(@lyndsie)
Member Moderator

CHMOD isn't PHP-specific. Any file stored has these permissions set (.txt, .html, .php, etc.). Here is a decent explanation of it: http://www.pageresource.com/cgirec/chmod.htm

As for changing it, it's hard to be specific without knowing your specific sever setup. It's really question for your host, as it's not eFiction-specific. In any case, usually there will be a file manager available, and you should be able to change the permissions in there.

For the question that is eFiction-related, to know if you're using files or database storage (although I suspect files), go to Admin > Settings > Submissions Settings and see what is selected under "Save files in:"

ReplyQuote
Posted : 30/03/2010 6:02 am
wolfiejinn
(@wolfiejinn)
Active Member

The thing is this is the same host, Market Hoster, that I had before.  I'm just not on the friend's account, but my own.  Same plan, everything.  None of this happened at the previous home.

Submission settings say file, though, thanks for that. 

Sorry I'm such a pain but it's just one more dang thing since the idiot whose account I had the website on A) insisted I take some crappy home built pc that he had to trash my decently working pc to finish off for my 'Christmas present' that didn't work, B) lost almost everything on the "new" PC's hard drive because he used sub-par, ancient crap he had laying around C) had to buy a brand new pc cuz my original one was no longer salvagable that's how wonderfully he screwed it up, and D) when I told him to buzz off, he'd screwed me over the last time I decide to move my websites in a hurry before he gets vengeful and E) now I can't get them to work on the new server.  It's been nothing but drama from this guy's idiocy since December.  I just want it to work. LOL!

So I went into File Manager, selected the fanfiction folder where I have the eFiction everything, changed permissions to 777.  I deleted the old post of the story I've been using as a test, deleted my temporary internet files (in case IE decided to reload the old page), added the story again (this time it gave me my category options which it didn't before so 777 did something!), but still no text.  (shakes fist in frustration)  Should I try 644?

Edit: Tried 644.  I couldn't even access the page that was the fan fiction archive from the website, gave me a 404 error.  I fail.

ReplyQuote
Topic starter Posted : 31/03/2010 3:37 am
wolfiejinn
(@wolfiejinn)
Active Member

Oooh! Ooh! An error message!!!  I went into the Legacy File Manager and changed the permissions for both the fanfiction and cgi-bin folders to 777 and when I uploaded story I got this:

Warning: fopen(stories/1/279.txt) [function.fopen]: failed to open stream: Permission denied in /home/sw323/public_html/fanfiction/stories.php on line 254

Warning: chmod() [function.chmod]: No such file or directory in /home/sw323/public_html/fanfiction/stories.php on line 260

I also noticed that if I click preview, I can see the text of the story, but when it's submitted....nada.

ReplyQuote
Topic starter Posted : 31/03/2010 3:50 am
Becca
(@becca)
Honorable Member

Did you make sure the files themselves are CHMODed? You might only be changing the permissions of the folders but not the files inside of them.

ReplyQuote
Posted : 31/03/2010 4:16 am
Tammy
(@tammy)
Member Moderator

You moved your files to a new server?  You probably need to CHMOD the files inside the folders in the stories folder to 666.

ReplyQuote
Posted : 31/03/2010 7:29 am
Lyndsie
(@lyndsie)
Member Moderator

Stuff could be different with your new account because it could be on a different server. Sometimes things will vary even within the same hosting company.

You don't really want to mess with permissions for anything beyond the config.php file (as specified in the install instructions) and the stories folder and its subfolders. Make sure that the stories folder and all the folders within it are at 777. If it still doesn't work, try CHMODing the .txt within the folders to 666 and see if it works. The problem with this is that eFiction creates these files at 644, so if you need it to be 666 then you'll have to mod the script. In my case, rather than do that, I talked with my hosting company, and they changed some stuff on their end to make 644 work.

ReplyQuote
Posted : 31/03/2010 8:05 am
Share: