Forum

Notifications
Clear all

Problem with Gmail registered members

Majestric
(@majestric)
New Member

URL to your eFiction: http://grangerenchanted.net
Version of eFiction: 3.5.5
Have you bridged eFiction, if so with what?: no
Version of PHP: 7.2
Version of MySQL: 5.7 (I think)
Have you searched for your problem: Extensively
If so, what terms did you try: Email Problems, Reviews Not Sending, GMAIL, Gmail Email Problems, Email Issues
State the nature of your problem: 

So at first when I signed up the site I used a Gmail as the admin email. Then I realized NONE of the messages sent via the site were reaching the intended recipient. It took me a while to figure out but I changed the site email to one not to do with Gmail- I used a domain registered email and presto when a review was posted, the author was notified.

However whenever I try to send messages via the other contact options (such as Contact Author, Contact Us, Rejection Letter, Acceptance letter), they either 1) won't go through, or 2) will go through if I'm using an email server other than Gmail. For some reason, Gmail just isn't working with the website.  I've tried it from multiple test accounts. If you're registered with a Gmail account, it just doesn't work.

Has ANYONE ran into this problem before? If so do you know how it was resolved? I've been working on this problem going on.... 13-16hrs almost straight,  and it's doing my head in. I'd be willing to pay to have this problem fixed. The entire website is ready to go but this is keeping it from happening

I can make a test account upon request. I just am truly stumped and would give just about anything to have this problem solved.

Quote
Topic starter Posted : 23/01/2020 9:08 pm
LD-MTT
(@ladama)
Trusted Member

Our site had the same issue with using a Gmail address as the admin email, our site is quite old and it may have worked once upon a time but it definitely doesn’t now.

What did the trick for us was to go to Admin > Settings > Site Information and enter a domain registered email address as “Admin Email” (which it sounds like you have done) and then go to Email Settings and make sure at the SMTP fields were blank (before they had gmail smtp info entered).

I’m not sure if I’m fully understanding the issue though, so your authors receive new review notifications, but they don’t get acceptance/rejection emails or “contact author” emails?

ReplyQuote
Posted : 08/02/2020 9:58 am
Jimmi
(@jimmi)
Active Member

URL to your eFiction: http://grangerenchanted.net
Version of eFiction: 3.5.5

Hi, did you solve this?  I will test this with my new efiction site, so I can look at this.
If I get your problem right,  you:
- use @grangerenchanted.net for admin email
- you don't use SMTP
- problem is only with user with gmail account
- and only with the other contact options (you listed them in your post)

The standard combination should be using  @grangerenchanted.net with SMTP, otherwise, Gmail blocks email as spam... 

EDIT:

Confirmed.  The reason is hosting provider antispam policy and that efiction use FROM (sender) email address from a form in some case.

Notification can be solved by SMTP settings (or correct admin email), because admin email is sender in those cases.
But for others forms  FROM address has to be siteemail.  Nowadays,  email input is added as reply to email not a sender. 

It works in some cases because user (sender) can use the same provider or hosting can be so no strict. But the error is:

SMTP server errir: DATA END command failed Detail: Blocked, unknown email address in envelope-sender or From header.  http://antispam. .sk/?from=*@gmail.com&sender=****@gmail.com SMTP code: 551

This is a common problem with older software...

ReplyQuote
Posted : 06/03/2020 10:04 am
Jimmi
(@jimmi)
Active Member

FIX for this, if anybody needs this:

open  includes/emailer.php

add $siteemail as next global variable

global $language, $smtp_host, $smtp_username, $smtp_password, $siteemail;  

Find the line with ->From (cca row 75) and change it to $siteemail, this email has to be email approved by your provider (in my case it has to email for my domain)

	$mail->From = $siteemail;

This solution fix all forms. For notifications, $siteemail is already used.

Sorry for my English.

ReplyQuote
Posted : 06/03/2020 11:47 am
Share: