Forum

Notifications
Clear all

Error when trying to post long chapters or one-shot stories

JessicaR
(@jessicar)
Active Member

Version of eFiction - 3.5.3

Site link - http://www.jezykfic.com/efiction/index.php

I have been working on setting this site up for a friend of mine (hence no stories posted yet).  To test things out, I tried to upload one of my short stories (rather lengthy, 36+ pages).  I believe I've put the settings to not limit word count, etc., however when I try to post the story I get the following error message:

"You must include the text of your story either as an upload or as input into the text area."

If I try to post something short and click "preview" there are no issues, so I know it has to do with the length.

I submitted a support ticket to my web host, but they said that all of their settings seem to be okay, and they don't think it should be affecting my ability to post with a lot of characters, etc.  They don't think it's an issue with "timing out" or anything like that, so they suggested I write to the developers here.

I have posted the same short story on www.svufiction.com which also uses eFiction, so I know for a fact it's possible to post the whole thing in one shot.  I don't want to break up the story into two chapters because it interrupts the flow.

I've scrolled through all of the support sections here on the forum, and I checked some settings in my stories.php file, but they don't seem to apply to me because I don't get any other error messages.  Just the one I listed above.

Help!   😐

Best,

Jessica

Quote
Topic starter Posted : 31/08/2011 1:03 am
babaca
(@babaca)
Member Moderator

Are you saving files to the database or in a stories folder?

If you are saving to a stories folder, have you actually created a folder call stories?

Is the stories folder chmod to 777 or 755?

******************************************
Mucking around in eFiction since circa 2001 (ver. 1.0)
Now running v.3

ReplyQuote
Posted : 02/09/2011 7:21 pm
JessicaR
(@jessicar)
Active Member

I have a "stories" folder, and it is set to 777.  The "stories" folder is located in the "efiction" folder (not in a sub-folder).

ReplyQuote
Topic starter Posted : 02/09/2011 10:18 pm
babaca
(@babaca)
Member Moderator

Are you sure in Settings you have it pointing to efiction/stories?

Also you might see if chmod stories to 755 will do anything. My webhost doesn't allow 777, so I use 755.

In Submission settings, (Admin->Settings->Submission Settings)  what do you have listed for Chapter word count limits? If you leave both Minimum and Maximum as 0 it sees it as unlimited size so it should interfere with file size.

******************************************
Mucking around in eFiction since circa 2001 (ver. 1.0)
Now running v.3

ReplyQuote
Posted : 02/09/2011 11:01 pm
Tammy
(@tammy)
Member Moderator

Check the naughty words list in the admin settings.  I've seen this happen when someone's put an invisible character in there and it's triggered the filter to filter everything.  While there you may also want to check what's in the allowed HTML list if your file contains HTML.  Try uploading a really short file.  This can also happen if your hosting provider has put a limit on the size of file uploads. 

ReplyQuote
Posted : 05/09/2011 1:18 am
Share: