Forum

Notifications
Clear all

Can't log in as admin after brand new install

Talullah
(@talullah)
Trusted Member

URL to your eFiction: http://www.ofelvesandmen.com/oeam/
Version of eFiction: 3.5.5
Have you bridged eFiction, if so with what?: No
Version of PHP: 5.3.26
Version of MySQL: I'm trying to figure it out. We're on Lunar Pages, if anyone knows what version they are using
Have you searched for your problem: Yes
If so, what terms did you try: after install can't log in
I tried several things I found under this search, including reuploading the user.php file and manually changing my password at the database. I wanted to turn register_globals on, but it says only the server administrator can do that - do I have to ask Lunar pages to do this for me?

State the nature of your problem: I did the install, created the admin account with password, deleted the install folder and tried to log in. Nothing happened - no error message, nothing. I tried requesting a password but it wasn't sent although it said so.

Do you have a test account for us? No.

Thank you for any help!

Quote
Topic starter Posted : 03/07/2015 11:15 pm
snapesflower
(@snapesflower)
Active Member

Tallulah,
Mine did the same thing to me at first. What I did was go into the phpmyadmin, go to authors, find my id which should be the first one, and under the box marked level, changed it to a 1.
That fixed my problem.

ReplyQuote
Posted : 03/07/2015 11:22 pm
Talullah
(@talullah)
Trusted Member

What I did was go into the phpmyadmin, go to authors, find my id which should be the first one, and under the box marked level, changed it to a 1.

Hi! Thanks for the tip... but I don't have the box you mention. I only see a level field in the authorprefs table. Anyway, after reading your message, I started looking at the other author tables. Authorinfo does not load anything. Isn't it supposed to have some fields...?

Again, thanks.

ReplyQuote
Topic starter Posted : 04/07/2015 1:38 am
Talullah
(@talullah)
Trusted Member

I tried registering another user but I also did not get the email with the PW

ReplyQuote
Topic starter Posted : 04/07/2015 1:56 am
banshee
(@banshee)
Member Admin

Hiya - it looks like Talullah is an Administrator.
No emails have appeared in your SPAM folder?

Authorprefs > Level should be set to 1 for the administrator, which it would be for Talullah since it's showing administrator under their profile.
Authorinfo should have 'uid', 'field', and 'info'. If they aren't showing, then there might be another install problem..

Did you want to email or PM me with your MySQL or hosting login so that I can track down the problem with the database? kimberly@retrogression.org.

eFiction Archives: Tom Paris Dorm | Twice Bitten | Underground

ReplyQuote
Posted : 04/07/2015 2:39 am
Talullah
(@talullah)
Trusted Member

Hi!

Thanks so much for being willing to take a look at it.

1. Yes, Talullah is the admin
2. Nope, unfortunately the emails are not in the spam and the same applies to the other account I tried to create
3. Authorprefs has Talullah with level 1
4. Author info has the fields you mention (I had not realized I had to click update *blushes*)

I've sent you an email with the logins. Thank you so much!

ReplyQuote
Topic starter Posted : 04/07/2015 10:36 am
banshee
(@banshee)
Member Admin

When I changed the administration email address on your account it seemed to work. It might be an issue with an @yahoo.com email address?

You might need to set up SMTP mail settings for yahoo accounts, but a gmail based service seems to have no problem for now.

eFiction Archives: Tom Paris Dorm | Twice Bitten | Underground

ReplyQuote
Posted : 04/07/2015 11:20 am
Talullah
(@talullah)
Trusted Member

When I changed the administration email address on your account it seemed to work. It might be an issue with an @yahoo.com email address?

You might need to set up SMTP mail settings for yahoo accounts, but a gmail based service seems to have no problem for now.

I registed with a gmail addie and then another and the same thing happened - no email.

When I registered with my outlook/microsoft based work email, I got an email with the pw, but then I could not log in after I changed the password - it said

That password doesn't match the one in our database. Please try again or retrieve a new password if you can't remember yours.

Might there be something more going on than just smtp?

ReplyQuote
Topic starter Posted : 04/07/2015 11:49 am
Talullah
(@talullah)
Trusted Member

When I changed the administration email address on your account it seemed to work. It might be an issue with an @yahoo.com email address?

You might need to set up SMTP mail settings for yahoo accounts, but a gmail based service seems to have no problem for now.

I logged in with your penname and changed the passwords for the other emails I had registed. I am now able to navigate the site while logged in.

When I changed the passwords at the admin panel, I got this message at the top of the screen:

line 135

Just that.

I still can't get the site to send emails to new registrees.

I got this message at the Version Check:

You are currently running eFiction version 3.5.5.
The current version of eFiction is 3.5.3
You need to update.

I downloaded the package yesterday from eFiction's main page and it's supposedly a newer version. Could this be causing the problem?

I was looking at the email settings, to change the smtp, but it says it should be left blank if I enabled sendmail, which I did, in the install.

ReplyQuote
Topic starter Posted : 04/07/2015 11:55 am
ShiKahr
(@shikahr)
Trusted Member

First of all a big THANK YOU for updating the Software. I was waiting for ages.

I also have the issue that a brand new installation doesn't create the first user as admin.
Before I upgrade from my existing version 3.5.2 to the new 3.5.5 on my live website (what has stories) I wanted to test and see if it's working and if something changed. So I installed a complete new clean version. Everythin was good, but I noticed that there is no Administrator Account. I expected the first user being an Admin, but it seems that he is a normal user with no Admin rights.

What did I wrong? And can I give that first user admin rights manually, maybe directly in the Database?

Thanks for your help in advance.

========================================
Solution:
Fact is, recently the installer has stopped creating the administrator with administration rights.
If you can directly access your SQL data, go to the authorprefs table and change level to 1.

KS-Shipping-Community
Get your Arsch out of the couch." Gayle Tufts

ReplyQuote
Posted : 17/10/2015 3:44 pm
Sheepcontrol
(@sheepcontrol)
Member Admin

As you already figured, the installer died at some point, I am not very 3.5, so I had no success figuring it out, so we usually quick-fix it - not exactly top notch, but it works  😳

ReplyQuote
Posted : 18/10/2015 12:52 am
muhkuh
(@muhkuh)
Eminent Member

As you already figured, the installer died at some point, I am not very 3.5, so I had no success figuring it out, so we usually quick-fix it - not exactly top notch, but it works  😳

Maybe there should be a fallback that checks if there is only one user and if so, then check if its a casual user; another positive? -> set it as admin.
Does that sound okay for a hotfix?

ReplyQuote
Posted : 21/10/2015 11:12 pm
Sheepcontrol
(@sheepcontrol)
Member Admin

Not happy with automatic things.

There's a glitch in the installer that has most likely been located thanks to the down-under intelligence department, need to run a few tests to figure the safest fix, not entirely sure though why it used to work and when it died.

ReplyQuote
Posted : 22/10/2015 12:12 pm
Share: