Notifications
Clear all

Error Upgrading from Version 2.0.7 to 3.5.3

9 Posts
2 Users
0 Reactions
3,227 Views
(@makoto-sagara)
Posts: 6
Active Member
Topic starter
 

URL to your eFiction: http://www.afallenangel.net/makotosagara/index.php
Version of eFiction: 2.0.7
Have you bridged eFiction, if so with what?: No
PHP version      4.4.9
MySQL version      5.0.92-community
Have you searched for your problem: Yes, but I haven't found anything that came close to my problem
If so, what terms did you try: MySQL error. access denied, line 21
State the nature of your problem: Fatal error: Call to undefined function: accessdenied() in /home/afallena/public_html/makotosagara/includes/mysql_functions.php on line 21
Do you have a test account for us? yes, username test, password: test

This is the fourth time I've attempted to upgrade from version 2.0.7 to 3.X.X... I get this on the first step about the tables. I try to select automatic, and this is what it gives me. I'm really not sure how to fix it and I'm about to rip myself bald here. Help?

 
Posted : 06/02/2012 3:54 pm
(@makoto-sagara)
Posts: 6
Active Member
Topic starter
 

Sorry, but it's been a while and I haven't heard anything back from someone who can help. Is there anything I can do? It's been severely discouraging to have this error every time I attempt to upgrade and not know how to fix it. Help?

 
Posted : 29/02/2012 1:13 pm
(@lyndsie)
Posts: 1263
Member Moderator
 

It seems like it's having trouble connecting to the database. Did you keep all the 2.0 files as they were and ensure that the config file was chmoded to 666?

 
Posted : 06/03/2012 11:17 pm
(@makoto-sagara)
Posts: 6
Active Member
Topic starter
 

I didn't make any changes to the files except for chmod'ing the config file to 666

 
Posted : 12/03/2012 6:23 pm
(@makoto-sagara)
Posts: 6
Active Member
Topic starter
 

Anyone have any suggestions?

 
Posted : 19/03/2012 12:20 pm
(@makoto-sagara)
Posts: 6
Active Member
Topic starter
 

No other suggestions?

 
Posted : 30/03/2012 2:43 pm
(@lyndsie)
Posts: 1263
Member Moderator
 

Sorry I didn't respond earlier. If you're still looking for help, ping back on this thread and I can try my best.

 
Posted : 28/05/2012 1:11 am
(@makoto-sagara)
Posts: 6
Active Member
Topic starter
 

Yes, I would like help, but maybe you can answer this. Is it possible that I do a completely fresh install somehow on my server and then add in the 2.0.7 info without doing the hard work of adding it all in by hand?

 
Posted : 31/01/2013 7:02 pm
(@lyndsie)
Posts: 1263
Member Moderator
 

If you mean for the SQL database, if you have a backup then you should be able to upload it. The same goes for the files, really. If you do a search on the forums there are several threads with instructions on how to do I think what you're describing (I remember answering the Qs), but that was for 3.0 and not 2.0. I never installed 2.0 from scratch and it's been probably 6 or 7 years since I dealt with it extensively.

IN THEORY if you have a copy of your 2.0 tables and upload that, and THEN upload the 3.0 files to the server as described in the upgrading info. You would need to have a 2.0 config file, also, and the stories folder if you use that instead of saving them to the db. Then when you view the site you should be prompted to run the upgrade to 3.0.

If your version of MySQL is the same as in your previous post then you should not have problems.

I don't know if that answers your question.

 
Posted : 01/02/2013 2:58 am
Share: