Forum

Notifications
Clear all

My webpage doesn't open

Devi R Black
(@devi-r-black)
Active Member

URL to your eFiction: www.thficcion.com
Version of eFiction: 3.5.3
Have you bridged eFiction, if so with what?:No
Version of PHP:  PHP 7
Version of MySQL:
Have you searched for your problem: Yes
If so, what terms did you try: IP, site doesnt work (and similars), segurity, safety, script error. I went through a large part of the support post.
State the nature of your problem: Well, my problem is: My site is unavailable as in when you write, click favs etc, the url or link the only thing that comes up is a "feedback" of the browser's information and IP of the computer/device, my hosting doesn't offer any programming help but they said that it was a problem with the script I was using.
    And the site "isithacked.com" send me a message about the cloaking and a difference of bytes here:
There is a difference of 47 bytes between the version of the page you serve to Chrome and the version you serve to GoogleBot. This probably means some code is running on your site that's trying to hide from browsers but make Google think there's something else on the page. show.
    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31
(this in red)
    Mozilla/5.0 (compatible; Googlebot/2.1; + http://www.google.com/bot.html) (this in green)
Do you have a test account for us? I have one, but as I can't access my site the normal way so...

I would really like some help, I know that maybe this isn't efiction related but I don't know what else to do, in fact I don't know what I'm looking for when I google my problem :sad1: :sad1:

Quote
Topic starter Posted : 04/12/2016 10:27 am
muhkuh
(@muhkuh)
Eminent Member

All I see when I open it up is some Internal Server Error... It's a basic message telling everyone that the webmaster has to take a look into the logfiles.

If you have access to them, please give us some information from the errors.log (Blank out IPs if there are any).
Otherwise ask your provider for assistance.

ReplyQuote
Posted : 04/12/2016 12:46 pm
Devi R Black
(@devi-r-black)
Active Member

Thank you so much for answering!
Since last night I went to my Cpanel and tried to check the error page (is in Spanish so I don't know if I'm looking in the correct place) but it sends me an empty register, nothing at all. The information message read something like 'This function will show the last 300 errors of you site. This could be very helpful to find broken links or problems with missing files..." but it comes out empty, even I tried to give it time of an hour and still shows nothing.

Update: I went into my public html, and download the error.log archive that came there on a txt archive, but then I started looking in every folder and have a few of those files... which one does help? The most recent has a error (or so I think):

[25-Nov-2016 14:50:29 UTC] PHP Deprecated:  Function ereg_replace() is deprecated in /home/thficcio/public_html/admin/backup.php on line 64
[25-Nov-2016 14:50:29 UTC] PHP Deprecated:  Function ereg_replace() is deprecated in /home/thficcio/public_html/admin/backup.php on line 64
[25-Nov-2016 14:50:29 UTC] PHP Deprecated:  Function ereg_replace() is deprecated in /home/thficcio/public_html/admin/backup.php on line 64

As of know my site is working again, but I'm afraid that this could happen again so yes, I still need to know what to do.

ReplyQuote
Topic starter Posted : 04/12/2016 6:53 pm
Sheepcontrol
(@sheepcontrol)
Member Admin

That's a classic, and it means that you are using an old version of eFiction 3.5.x, this bug was fixed a while ago.

- Backup your files (download to your computer)
- Get the latest eFiction 3.5.x files from https://github.com/eFiction/v3_stable/archive/master.zip and update your web files.

Add: deprecated means, this function will be removed in a future version of PHP, so it's highly recommended to do the above steps. I did mention doing a backup, just in case?

ReplyQuote
Posted : 04/12/2016 11:48 pm
Devi R Black
(@devi-r-black)
Active Member

Thank you!
I would do this.

ReplyQuote
Topic starter Posted : 05/12/2016 10:15 pm
Share: