• November 17, 2018, 05:43:40 am
• Welcome, Guest. Please login or register.
 
News: It's been a while since we started working on eFiction 5, there's been a lot of starting from scratch and half-scratch, but things are moving on.
Now we need you: please visit the eFicition 5 section of the forum and raise your voice, shape the new face of your favourite fanfiction management software.

Author Topic: unable to edit stories: add button doesn't appear after preview  (Read 3579 times)

LN Tora

  • Newbie
  • *
  • Posts: 4
Hello.  Large problem for me.  This morning I got an email from a writer saying she couldn't save an edited story.  I just tried myself and have the same problem.  After hitting preview for the first time, it showed the text, but the form hangs for a moment, then it stops at the textbox for the story.  Some of the text there gets cut off, and the preview and add story buttons are missing.

I'm storing the fics in a DB, I can't remember all the mods, but I don't think they're related as this seems to have occurred within the last 48 hours.  I did try to install the security patches yesterday, but removed them prior to posting to see if that might have caused it.  (I'm guessing no, since the problem's still there.)  I don't get any error messages that I can see, though I'm wondering if something is just timing out somewhere.

Any help on this matter is greatly appreciated, thank you.

Carissa

  • Global Moderator
  • Veteran
  • ****
  • Posts: 2437
Re: unable to edit stories: add button doesn't appear after preview
« Reply #1 on: July 11, 2006, 05:42:47 pm »
I don't see anything wrong on first-glance.

Save a copy of the stories.php (or change the name) and upload a new one to see if this fixes your problem.

LN Tora

  • Newbie
  • *
  • Posts: 4
Re: unable to edit stories: add button doesn't appear after preview
« Reply #2 on: July 11, 2006, 07:08:00 pm »
The glitch seems to occur depending on the story length.  One story in my account is approx. 5k+ words, and the text gets cut off, and the buttons don't appear.  At the point of cut-off I see 0.  The writer who emailed, her story is approx 3k+, and there's a weird textbox with no label.  I tried a shorter story of my own, 1018 words, and there's no problem.

I compared a clean copy of the file to my modded one, but I don't see where any of the changes would affect editing in such a way.

I've included links to a couple of screenshots of what happens after hitting preview on both my story and the other writers.

image 1
image 2

Carissa

  • Global Moderator
  • Veteran
  • ****
  • Posts: 2437
Re: unable to edit stories: add button doesn't appear after preview
« Reply #3 on: July 11, 2006, 07:25:57 pm »
This is a problem with the way the database is set up then. It happens quite often, actually. It's either one of two problems.

1) The text is too long to fit into the database as it's set up by default. If you can get into your database using phpMyAdmin, you can change it fairly easily. Select your fanfiction_stories table and click on structure. Then select the "storytext" row and click on change or edit. Change the type from "text" to "longtext" from the dropdown menu. That will allow for longer chapters.

This does come with a few risks though. One is the upload timing out, especially for dial-up users, and two is that a lot of very long stories will make your database, and consequently, your site, run slowly. You really do this at your own risk. I honestly don't recommend it.

2) It could be that the upload is timing out. MySQL will only keep an action open for a certian amount of time before it just stops. I don't know of any way for you to fix this. Though if this does turn out to be the problem, you might contact your host to see if they can help you.

Since the page isn't loading properly after you preview the changes, I'm guessing that this is actually your problem. :(
« Last Edit: July 11, 2006, 07:28:31 pm by Carissa »

LN Tora

  • Newbie
  • *
  • Posts: 4
Re: unable to edit stories: add button doesn't appear after preview
« Reply #4 on: July 11, 2006, 07:27:44 pm »
I thought it might be, but I wouldn't have known what to change myself.  I'll try the first method and let you know.  My host is nice, so if it turns out to be the second, he might can help.  Thanks for the assist!  I'll post later with the results.

LN Tora

  • Newbie
  • *
  • Posts: 4
Re: unable to edit stories: add button doesn't appear after preview
« Reply #5 on: July 11, 2006, 07:32:46 pm »
Well I just tried the first method, but I'm still seeing the problem, so I'll have to assume it's timing out.  Though would it really be with the database itself if it's the preview that's causing the problem?  When I hit the edit link initially, all the text is in the textbox.  It's after hitting preview that the problem occurs.

I'll still see if my host might be able to help, though.  Thanks again.