Clear all

500 - Internal Server Error

6 Posts
4 Users
Posts: 13
Active Member
Topic starter

URL to your eFiction:
Version of eFiction: 3.5.5
Have you bridged eFiction, if so with what?: no
Version of PHP: 5.4.39
Version of MySQL: 5.5
Have you searched for your problem: yes
If so, what terms did you try: 500 internal server error, 500, web.config file
State the nature of your problem:

500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

I am using godaddy as my webhost. I am apparently missing a web.config file to be able to go on to the next step in the installation process. Any assistance would be greatly appreciated.

Do you have a test account for us? no, haven't gotten far enough into the installation process to start an account

Posted : 26/04/2015 7:44 pm
Posts: 332
Reputable Member

Visited the site, only showed some image, so couldn't check it out.

There is no such thing as a web.config file in eFiction, so this may be a godaddy thing.

Posted : 02/05/2015 7:50 am
Posts: 27
Eminent Member

Wow, one even has to play around with the DOM-Tree / CSS to see the message  πŸ˜€

It only tells me the website is on Maintenance (404, file not found background image?) with a CSS-File that could not be loaded, because the host its said to be on cannot be resolved ( http://img1.wsimg-com.ide/ux/dev/css/uxcore.css )

Future home of something quite cool.

If you're the site owner, log in to launch this site

If you are a visitor, check back soon.

To be honest, THIS doesnt look like an eFiction for now problem πŸ˜‰

Posted : 06/05/2015 2:49 pm
Posts: 131
Estimable Member

I put in index.php at the end of the address and got to the efiction config. Also, isn't web.config an .Net thing - so this is Windows hosting? Does that work for efiction (I'm not saying it doesn't, I just don't know)...maybe it does because I can get to the start of the install.

Anyway, back in the day, a site had a pecking order of files to display in a directory, so check to see if there's another index or default file that's over-riding your index.php file OR check the server config somehow (I'm sorry I don't know the technical terms but if you contact the host's support, they should know what I'm talking about).

If there's a default.htm (or similar) in the /manorfiction directory, just try renaming it to default.old (or even 1default.old, in case "default" persists) and then see if you can get to the setup.

Posted : 17/05/2015 5:42 am
Posts: 13
Active Member
Topic starter

I took another look at this problem, and it looks like I have a permission error with Windows. Does anyone know what permissions would be similar to 755 in Plesk. This is what it looks like through my control panel:

Group or user names Inherited from
<not inherited>
Application pool group (IWPG_mikmicdavpet)
Plesk FTP subaccount (manorfiction) G:PleskVhostsmonkeemanor.netmanorfiction.monkeemanor.netinstall
Plesk FTP subaccount (manorfiction)
Plesk Domain User (mikmicdavpet)
Administrators <not inherited>
SYSTEM <not inherited>
Application pool group (IWPG_mikmicdavpet) <not inherited>
Plesk FTP subaccount (manorfiction) <not inherited>
Plesk Domain User (mikmicdavpet) <not inherited>
Permissions for Administrators Allow Deny
Full Control
Read Control
Write Control
Execute Control
Traverse Folder / Execute File
List Folder / Read Data
Create Files / Write Data
Create Folders / Append Data
Change Permissions
Take Ownership

Any assistance would be greatly appreciated! Thanks!


Posted : 23/05/2017 11:08 pm
Posts: 131
Estimable Member

This page has a video on setting permissions in Windows/Plesk. I'm not sure how appropriate it is, sorry. I've never run a server in anything other than Linux.

Posted : 28/05/2017 5:40 pm