login
• January 16, 2018, 08:47:45 am
• Welcome, Guest. Please login or register.
 
News: It's been a while since we started working on eFiction 5, there's been a lot of starting from scratch and half-scratch, but things are moving on.
Now we need you: please visit the eFicition 5 section of the forum and raise your voice, shape the new face of your favourite fanfiction management software.

Author Topic: tinyMCE Not Showing Up  (Read 1093 times)

taemin

  • Newbie
  • *
  • Posts: 3
tinyMCE Not Showing Up
« on: April 29, 2013, 02:15:15 pm »
Hi, I recently set up a fanfiction archive over here and it seems that no matter what I do, tinyMCE wouldn't bother showing up. I searched this forum and tried out different methods (edited the header.php with anything that referenced to the tinyMCE script, replaced the updated tinyMCE with version 3.x, etc.) and much to my disappointment, nothing seems to work. I'm stuck! I would really want to see the word editor instead of the plain textboxes.

Is there anything else that I forgot to do or I have done wrong?

babaca

  • Global Moderator
  • Veteran
  • ****
  • Posts: 1213
  • Thanked: 1 times
    • babaca fanfics
Re: tinyMCE Not Showing Up
« Reply #1 on: April 29, 2013, 03:40:40 pm »
I think your wrote your website down wrong or took it down because I don't see it anywhere.

TinyMCE needs to turn up in two places.
When you first log in and it's under your personal preferences (a/k/a account info) Member Account
Click on Edit Preferences.
Make sure use TinyMCE is checked.
Click Submit

Then under Admin preferences (for the entire website) (If you are already logged in to your member account and you are the admin click ADMIN)
Click on Settings
Click on Site Settings
Where it says Use TinyMCE WYSIWYG editor, make sure the pulldown is set to YES
Click Submit.

Log out of your site and log in again and it should work. Or don't log in and try use contact, or leave review and see if tinyMCE shows up.


If that doesn't work you may need to go ahead and update tinyMCE to the latest version.  http://www.tinymce.com/download/download.php
You would have to replace the tinyMCE folder in eFiction to do it, but it may resolve your problem.
« Last Edit: April 30, 2013, 11:58:39 pm by babaca »
******************************************
Mucking around in eFiction since circa 2001 (ver. 1.0)
Now running v.3

SJP

  • Member
  • **
  • Posts: 63
  • Country: 00
Re: tinyMCE Not Showing Up
« Reply #2 on: April 29, 2013, 10:49:04 pm »
I'm assuming this is your site: http://exo.tokkiberry.com/index.php. I have no idea if this will help, but I had a number of problems with TinyMCE when upgrading my site. I got the newest version of TinyMCE and replaced the one that came in the efiction download. Then in the admin panel, under settings, I removed all the information listed in the TinyMCE configuration and just edited the tinyMCE.init in the header.php file so it would have the buttons I wanted. Those steps, along with the ones babaca mentioned above got TinyMCE to work properly on my site.

taemin

  • Newbie
  • *
  • Posts: 3
Re: tinyMCE Not Showing Up
« Reply #3 on: April 30, 2013, 06:43:43 am »
Thanks guys! I followed exactly as you said!
Initially, I tried to replace the tinyMCE folder that came with eFiction to the updated tinyMCE 4.0b2. When that didn't work, I downgraded to tinyMCE 3.

So I followed babaca's instructions and I realized that all I had to do was change the preferences under my personal instead of the admin. I changed the folder back to tinyMCE 4.0b2 and now I see the editor in the textareas, albeit that the editor is at the bottom of the text box, but I guess I can live with that for now. (Unless someone has a solution for that as well?? I just changed the code in the header and the editor is back on the top of the textbox!)

Anyhow, thank you! I definitely did miss something!
« Last Edit: April 30, 2013, 11:52:41 am by taemin »

babaca

  • Global Moderator
  • Veteran
  • ****
  • Posts: 1213
  • Thanked: 1 times
    • babaca fanfics
Re: tinyMCE Not Showing Up
« Reply #4 on: April 30, 2013, 11:58:59 pm »
Glad we could help.
******************************************
Mucking around in eFiction since circa 2001 (ver. 1.0)
Now running v.3

Kate

  • Veteran
  • ***
  • Posts: 145
    • Millenium Psychics
Re: tinyMCE Not Showing Up
« Reply #5 on: January 10, 2018, 12:42:56 am »
Hi

I followed the instructions as well and even reuploaded the tinymce incase I had missing files and folders in the root. I have turned it on in the admin to yes and seen the tinymce configuration link but nothing shows up in the forms.

what am I missing please? I even turned it on in my own preferences as well.

I'm using efiction 355 and my site is location here http://www.adriftindreams.com

many thanks
Kate

Kate

  • Veteran
  • ***
  • Posts: 145
    • Millenium Psychics
Re: tinyMCE Not Showing Up
« Reply #6 on: January 10, 2018, 01:16:39 am »
In another post it says to turn the tinymce off on the site settings but turn it on in ur user panel under edit preferences. This has now worked for me but I seem to be missing some of the plugs. I would rather like to use the emotions for custom pages and other areas of my site but it only has a plugin for showing images. how do I get that to work please. I re uploaded all the tinymce folder again incase I had missing folders and files. No smilies turn up in the editor.

regards
kate

Kate

  • Veteran
  • ***
  • Posts: 145
    • Millenium Psychics
Re: tinyMCE Smileys Not Showing Up
« Reply #7 on: January 11, 2018, 09:48:25 pm »
Hi

ive checked again and I had to upload the smiley plug but now I got to add in the code to the toolbar in the editor as this
tinymce.init({
  selector: "textarea",  // change this value according to your HTML
  plugins: "emoticons",
  toolbar: "emoticons"
});


I have no clue where the toolbar is located in the files of tinymce can u help me please as I would like to use smileys
on my website :)

regards
Kate

 

anything
anything